ListSubscribe WILL NOT WORK

Dec 19, 2011 at 4:18 PM

        Dim lsi As New listSubscribeInput()
                        lsi.parms.apikey = "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-us4"
                        lsi.parms.id = ListID
                        lsi.parms.email_address = CustomerEmail

                        Dim ls As listSubscribe = New listSubscribe(lsi)
                        Dim lso As listSubscribeOutput = ls.Execute()

It all appears to work fine. The result comes back TRUE, there are no errors whatsoever, yet the email does not appear in the list on the MailChimp website. I have tried so many different samples and I done know what I'm doing wrong. This code above is obviously the most simple of my attempts, but no matter what I try the email never appears in the list. Yet the API seems to want to tell me it was fine.

Dec 21, 2011 at 6:34 PM

I'm having the exact same issue. this is happening both with the lates 1.3 beta release and the last stable release. Yet I find it hard to believe that this is a true bug given the likely hood that the listSubscribe method is probably the most used method in the api. So I'm thinking that there is something fundamentally wrong with the way I'm setting this up.

anyone else seeing the same problem?

Dec 22, 2011 at 9:12 AM

Did you guys see my project?

http://balexandre.com/mcapi_cs/

you can download the code at

http://ge.tt/9q0XzW4/v/1

 

and I show how to use some of the methods, subscribe and unsubscribe is a listing method that you can easily see how everything is configured and how you should work with the API.

 

I hope it helps.

May 19, 2012 at 7:56 PM

Hi all,

Have written a step-by-step walk through on my blog detailing exactly how to subscribe a user to MailChimp using the PerceptiveMCAPI in .NET

http://mattjroden.com/post/2012/05/19/Mailchimp-Subscribe-form-in-ASPnet-VB-C.aspx

 

Hope it helps!

 

p.s. Don't forget to like/comment/share if it's helpful!